Shared Mailbox Creation Temporarily Unavailable

Incident Report for Hiver

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 01:02 PDT

Investigating

Due to an ongoing Google authorization issue, creating new Shared Mailboxes and reauthorizing Google user or group inboxes is currently unavailable. Our team is actively working with Google to resolve this at the earliest.
If you need any assistance, please reach out to support@hiverhq.com.
Posted Mar 31, 2026 - 08:34 PDT
This incident affected: Third Party Services (Google Apps Gmail).